太平洋软件资讯

关于本文档的说明

本文档由太平洋软件资讯栏目制作，版权归太平洋软件资讯站 及文档作者所有。制作该文档的目的是为了方便广大网友。因此任何人都可以自由复制，或在网络中散布该文档。但不允许将该文档用于出版或其它商业用途，同时使用该文档的过程中，未经允许，不得对该文档进行修改及反编译。如有问题请与我们联系谢谢！


太平洋软件咨询， 在这里你将找到你想要的东西。来看看吧，每天都有大量更新，不会让朋友们失望的。

网页制作常见问题解答［一］

作者：田涛

1. 怎 样 定 义 网 页 语 言( 字 符 集)?

----在 制 作 网 页 过 程 中, 你 首 先 要 定 义 网 页 语 言, 以 便 访 问 者 浏 览 器 自 动 设 置 语 言, 而 我 们 用 所 见 即 所 得 的HTML 工 具 时, 都 没 有 注 意 到 这 个 问 题, 因 为 它 是 默 认 设 置。 要 设 置 的 语 言 可 以 在HTML 代 码 状 态 下 找 到:

< meta http －equiv="Content Type" content="text/html; charset=gb2312" >

----把charset=gb2312 改 换 成 其 它 语 言 代 码 即 可, 比 如 英 文:charset=en.

2. 怎 样 防 止 别 人 把 你 的 网 页 放 到 框 架 里?

----因 为 框 架（frame） 的 缘 故, 有 许 多 人 把 别 人 的 网 页 放 置 到 自 己 的 框 架 里, 使 之 成 为 自 己 的 一 页。 如 果 你 要 防 止 别 人 这 样 做, 可 以 加 入 下 列JavaScript 代 码 即 可, 它 会 自 动 监 测, 然 后 跳 出 别 人 的 框 架。

< script language="javascript" >
牋?if (self != top) { top.location = self.location; }
< /script >

3. 怎 样 设 置 字 体?

----在 制 作 网 页 过 程 中, 大 家 都 喜 欢 使 用 漂 亮 的 字 体。 但 是, 如 果 访 客 浏 览 器 没 有 安 装 同 样 的 字 体， 看 到 你 的 网 页 会 是 很 普 通 的 字 体。 如 何 防 止 这 种 情 况 出 现 呢? 大 家 知 道 字 体 设 置 的 标 签 是Font, 而 它 有 个 属 性 是Face, 该 属 性 是 定 义 字 体 的, 你 可 以 这 样 设 置:, 访 客 的 浏 览 器 就 会 按 照Face 定 义 的 字 体 顺 序 设 置 已 安 装 的 字 体。 目 前 动 态 主 页 有 种 技 术, 可 以 把 字 体 信 息 用 向 量 格 式 存 储, 然 后 利 用 访 客 本 身 机 器 含 有 的 公 共 信 息 库 把 字 体 快 速 的 组 装 起 来, 这 样, 就 不 用 担 心 访 客 是 否 安 装 有 某 种 字 体 了。

4. 怎 样 在 网 页 中 加 入 注 释?

----在 共 同 开 发 网 页 中, 加 入 注 释 是 防 止 分 工 被 搞 混 淆 或 者 注 释 某 段 代 码 特 殊 的 含 义, 加 入 注 释 的 格 式 是:

< ! － － Microsoft FrontPage 3.0 － － >。

5. 怎 样 测 试 浏 览 器 并 自 动 装 入 所 需 要 的 网 页?

----目 前 微 软 和 网 景 的 浏 览 器 并 不 能 完 全 兼 容 所 有 网 页, 有 的 在 某 种 浏 览 器 里 非 常 漂 亮, 而 用 其 它 浏 览 器 查 看 时 却 一 团 糟。 如 果 你 需 要 测 试 浏 览 器, 可 以 加 入 以 下JavaScript 代 码 并 保 存 单 独 一 个 网 页:

< script LANGUAGE="JavaScript" >
function TestBrowser(){
ie = ((navigator.appName ==
"Microsoft Internet Explorer") ＆ ＆
(parseInt(navigator.appVersion) >= 3 ))
ns = ((navigator.appName == "Netscape") ＆ ＆
(parseInt(navigator.appVersion) >= 3 ))
if (ns) {
setTimeout('location.href="nn4.htm"',10);
} else {
setTimeout('location.href="ie4.htm"',10);
}
}
< /script >

实 例 请 参 考:

http://www.netease.com/～tiantao/test.htm

6. 怎 样 让 链 接 没 有 下 划 线?

----只 要 在 加 入 以 下 代 码, 所 有 链 接 就 都 没 有 下 划 线 了:

< style type="text/css" >
< ! － －
A{text －transform: none;
text －decoration: none ;}
a:hover { text －decoration:underline }
－ － >
< /style >

7. 怎 样 在 网 页 中 加 入E-mail 链 接 并 显 示 预 定 的 主 题?

A HREF=mailto:lovett@163.net?subject=test

8. 怎 样 让 背 景 图 像 不 滚 动?

----Internet Explorer 浏 览 器 支 持 一 个Body 属 性Bgproperties, 它 可 以 让 背 景 不 滚 动。

< Body Background="c98.gif" Bgproperties="fixed" >

9. 怎 样 评 定 网 页 的 级 别?

----在IE4.0 浏 览 器 中, 有 一 项 功 能 是 过 滤 网 站 的, 一 些 受 限 制 的 网 站 被 过 滤 掉, 而 该 网 站 必 须 被RSAC( 美 国 娱 乐 委 员 会) 评 定 了 级 别IE4.0 才 能 过 滤, 如 果 你 要 评 级 可 以 在 网 页 中 加 入 以 下 代 码:

< meta http －equiv="PICS －Label"????
content='(PICS －1.1 "http://www.rsac.org/ratingsv01.html"
牋?l gen true comment "RSACi North America Server"
牋?for "http://youHostname"
牋?on "1998.11.26GMT08:15 ?0500"
牋?r (n 0 s 0 v 0 l 0))'>

10. 怎 样 定 义 本 网 页 的 关 键 字?

----在 网 页 中 加 入 关 键 字, 可 以 供 某 些 搜 索 站 台 机 器 人 的 使 用, 它 们 会 利 用 该 关 键 字 为 你 的 网 站 做 索 引, 这 样, 当 别 人 用 关 键 字 搜 索 网 站 时, 如 果 你 的 网 页 包 含 该 关 键 字, 那 么 就 可 以 被 列 出 了, 定 义 本 网 页 关 键 字, 可 以 加 入 以 下 代 码:

----< meta name="Keywords" content="china,enterprise,business,net" >

----Content 所 包 含 的 就 是 关 键 字, 你 可 以 自 行 设 置。

----这 里 有 个 技 巧, 你 可 以 重 复 某 一 个 单 词, 这 样 可 以 提 高 自 己 网 站 的 排 行 位 置, 如:

----< meta name="Keywords" CONTENT="china,china,china,china" >

11. 怎 样 链 接 本 网 页 的 对 象?

----有 时 链 接 发 生 在 一 个 网 页 里, 比 如 页 面 上 半 部 分 列 出 了 目 录, 下 部 分 就 列 出 了 内 容, 而 单 击 目 录 任 何 一 个 项 目 都 可 以 跳 到 指 定 部 分, 可 以 在 要 被 链 接 的 内 容 部 分 设 置 如 下 方 式:

< A NAME=" ＃t1" >< /A >

而 要 链 接 到 以 上 设 置 的 部 分, 可 以 如 下 编 制:

< A HREF="index.htm ＃t1" >t1< /A >

12. 怎 样 为 不 支 持 框 架 结 构 的 浏 览 器 指 定 内 容?

----为 了 防 止 不 支 持 框 架 结 构 的 浏 览 器 访 问 你 的 网 页, 可 以 在 你 的 网 页 中 加 入 以 下 内 容:

< body >
< noframes >
本 网 页 是 框 架 结 构, 请 下 载 新 的 浏 览 器 浏 览
< /noframes >
< /body >

13. 怎 样 删 除 表 格 边 框?

----有 时 需 要 删 除 表 格 的 边 框, 你 可 以 把Border 设 置 为 如 下 代 码:
< body >
< table border="0" width="100 ％" >
< tr >
< td width="100 ％" >< /td >
< /tr >
< /table >
< /body >

14. 怎 样 隐 藏 在 状 态 栏 里 出 现 的LINK 信 息?

----大 家 知 道, 当 你 指 向 一 个 链 接 时, 该 链 接 的 信 息 会 出 现 在 浏 览 器 状 态 栏 里, 如 果 需 要 隐 藏 信 息, 可 以 如 下 设 置:

< a href="http://c98.yeah.net" onMouseOver="window.status='none' ;
return true" >test< /a >

15. 怎 样 在 网 页 中 加 入 多 媒 体 文 件?

----有 些 多 媒 体 文 件 无 需 其 他 程 序 就 可 以 播 放, 而 有 许 多 多 媒 体 文 件 需 要 外 部 程 序 的 帮 助, 当 浏 览 器 下 载 不 支 持 的 格 式 时 会 调 用 外 部 程 序。 如 果 浏 览 器 没 有 安 装 这 种 外 部 程 序, 那 么 浏 览 器 会 自 动 去 下 载； 如 果 你 需 要 加 入 多 媒 体 格 式, 可 设 置 如 下 代 码:
< EMBED SRC="tt.ram" AUTOSTART="TRUE" LOOP="2" WIDTH="80" HEIGHT="30" >

----对 于 不 支 持EMBED 标 签 的 浏 览 器, 可 以 改 用 标 签。

16. 怎 样 在 网 页 中 加 入 电 子 邮 件 表 单 提 交?

----表 单 提 交 需 要CGI 程 序 的 支 持, 但 你 也 可 以 利 用E mail 提 交, 当 你 设 计 好 表 单 后, 把Action 内 容 加 入 邮 件 地 址 即 可, 如 下:
form method="POST" action="mailto:lovett@163.net" ENCTYPE="text/plain">

17. 怎 样 隐 藏 热 讯 分 析 的 图 标?

----热 讯 分 析 是 许 多 网 友 使 用 的 服 务, 它 能 帮 助 你 分 析 网 站 的 流 量, 如 果 你 想 隐 藏 该 服 务 图 标, 可 以 把 服 务 代 码 中 的 width=88 height=31 都 改 为1 即 可。

18. 怎 样 在 网 页 中 加 入 最 后 修 改 日 期?

----在 中 加 入 以 下 代 码 即 可:
< Script Language="Java Script" >
document.write
(" 最 后 修 改 日 期" ＋document.lastModified);
< /Script >

[返回]


网页制作常见问题解答[二]

作者:田涛

1.创建一个吸引人站点的步骤是怎样的?

要创建一个吸引人的站点,请考虑以下建议:

1)谁该是你的访客,是喜欢音乐的,还是喜欢玩游戏的;
2)是什么内容能吸引这些人,更快更新的信息,还是提供更多的下载;
3)如何让访客停留呢,当然不要用BUG,比如让访客的机器死机;
4)是什么能让访客再来呢,比如说明天有好东西,记得来呀,不过别骗人;
5)制定自己的目标,实现它;
6)征求大家的意见,然后逐步改进.

2.如何创建一个调查表?

越来越多的站点需要交互性来吸引访客,当论坛失去新意后,建立一个调查表,可以让访客选择你设置的问题,并让访客马上看到结果.

连接站点http://www.beseen.com/quiz/quizsignup.html,填写姓名及电子函件地址并选择你的站点类别，单击Accept按钮，这样过一会就能收到站点的回复了，期中提供了HTML代码，接下来设置调查表内容,最后把代码加入到自己页面中即可.

详细设置请下载FAQ.ZIP

3 .如何让一段文本排版兼容IE4.0和NN4?

有时侯,你设置的一段文本在IE4.0里浏览良好,但到NN4浏览器里,发现一段文本变成了一行文本,实在令人心烦,这时,你只需对照NN4浏览器里的文本,在需要分行的地方加入<BR>元素即可,这不会影响在IE4.0里的浏览.

4.如何打开一个新的浏览器窗口并设置窗口的属性?

如果你需要在载入站点的同时,再打开另一个新窗口,加入以下代码即可:

<script language="JavaScript">
<!--
var gt = unescape('%3e');
var popup = null;
var over = "Launch Pop-up Navigator";
popup = window.open('', 'popupnav', 'width=160,height=160,resizable=1,status=yes,menubar=no,scrollbars=yes');
if (popup != null) {
if (popup.opener == null) {
popup.opener = self;
}
popup.location.href = 'pop.htm';
}
// -->
</script>

期中pop.htm可以设置为你的HTML文件,对于设置新窗口的属性,对照以下设置:

popup = window.open('', 'popupnav', 'width=200,height=170,resizable=1,scrollbars=auto');

width:宽,height:高,resizable:是否允许访客缩放新窗口,scrollbars:如果文本超过一屏,是否生成滚动条,
status:是否显示状态栏,menubar:是否显示菜单,location:是否显示地址栏.

以上所有属性使用格式为:属性=yes 或者 no.而width和height两个属性为:width=#pixels,height=#pixels.

5.怎样判断服务器使用的操作系统?

在浏览器地址栏里,输入要察看的服务器地址,一定要包含目录和文档名字,比如:

http://www.netease.com/~tiantao/c.htm

然后回车,出现请求页面,试着把文档名改为大写格式,如果返回该页面不存在,那么可能该服务器使用的操作系统为UNIX或Macintosh,如果页面内容返回,那么可能该服务器为Windwos操作系统,因为Windows对大小写不敏感.

6.怎样提高站点在搜索引擎中被搜索到的机会?

当你把自己站点登记到搜索引擎中后,并不表示你的站点就会被经常搜索到,如何提高这个几率呢,很简单,你的主页一般会有一个标题,一般设置在<title></title>中间,这时,你可以在设置完标题后,跟着把关键字也设置在这里,比如:<title>田涛的网站-china,love,dhtml,tiantao,yahoo</title>.因为搜索引擎会首先察看站点的标题,并把标题作为你站点的关键字,当你把关键字也设置在了标题中后,搜索引擎也会加入这些关键字,这比其它所有的方法都好,唯一缺点,你站点标题变长了.

7.如何测试网站的下载速度?

准备一个能读秒的表,比如跑步表,这样精度高些,当然也可以使用普通的表.

首先我们测试纯文本的下载时间,打开浏览器,关闭下载图片功能,然后连接上网,在地址栏输入站点地址,回车后,计时开始,当全部文本内容下载完后,停止计时.

如果你要测试整个站点下载速度,打开图片下载功能,如果你站点含有JavaScript,也要在浏览器选择为支持,同上,打入地址,回车,计时开始,当所有内容下载完后,停止计时.

经过以上两种测试,你就会对自己站点的连接下载速度,作到心中有数了.

8.如何让站点自动跳转到另一页?

加入以下代码到HTML文件中即可:

<META HTTP-EQUIV="Refresh" Content=" 6;URL=xxx.htm">

"6"为停留的秒数,xxx.htm是将要跳转的页面.

9.怎样让广告随机出现?

当你想展示许多广告,但页面空间不够时,你可以让广告随机出现,你只需要加入一段代码.

--详细设置请下载FAQ.ZIP

--样本
10.如何知道我的站点连接出现的地方?

可能你的站点被其它站点连接,如何知道呢,访问搜索引擎站点:

http://www.altavista.digital.com/

在搜索窗口中,输入:+link:yoursite.com-host:yoursite.com

这样,包含你站点连接的页面被列出,当然,你也可能什么都没有找到.

11.如何避免自己的图片被其它站点利用?

为图片起一个很怪的名字,这样可以避免被搜索到,还可以利用photoshop的水印功能加密.当然,你也可以在自己的图片上加上一段版权文字,比如标明自己的名字-tiantao.因为文字体来就在图片上,除非使用人截取图片.不然就是侵权了.

12.如何不利用表格而准确的分隔图片和文字?

在页面中想要分隔图片和文字,利用表格是非常好的方法,你还可以制做一个透明的GIF图形,因为图形是透明的,你就可以拿来分隔图片和文字了,当然要注意透明图的大小.

13.如何跳到页面的顶部?

当浏览者浏览到页面底部后,你需要提供一个单击,让浏览者方便的跳到页面顶部,加入以下代码:

<a href="#top">返回到上面</a>

14.有什么简单的方法编写Cookie?

Cookie是信息小饼干,记录着浏览者的信息,你可以利用META标签编写最简单的Cookie并加入到页面中:

<META HTTP-EQUIV="Set-Cookie" Content="MyVar=你的页面过期了;expires=Thursday,15-4-99 00:00 GMT+8:00; PATH=/">


网页制作常见问题解答[三]

1.如何在一个站点不同页面间播放同一种声文件？

大家有这样的经验，当你访问一个站点首页时，会听到该页设置的背景声音文件，比如一段音乐。当你链接到该站点另一页时，音乐就停止了。如何让声音不断呢。其实，你只需要建立一个上下框架结构的网页，把声音文件建立在下框架里，并把下框架的宽度设置为一个像素，而上框架里是页面内容，当访问者离开站点首页时，因下框架内容未变，所以，声音不会间断。大家还要注意两点，第一，把框架的边框设置为0；第二，隐藏声音文件的播放界面，然后把上下两个框架的背景设置为相同。

2.如何让访问者能更多的单击付费旗帜广告？

拥有个人站点的网友都会去申请一些付费的广告，以得到一些网费补助。但很可惜，即使你经常请求访问者为了支持本站建设，请单击旗帜广告。遗憾的结果是，还是很少有人单击。要想让访问者能更多单击你的旗帜广告，有两种方法：

第一种：强化印象

让那个旗帜广告一直出现在访问者面前，让他不得不好奇的单击一下。你可以建立一个上下框架的页面，把旗帜广告放置在任意一个框架里。这样，只要访问者不离开你的站点，旗帜广告会一直出现在他们的面前。还要提醒你，不要在广告下面写上“为了本站发展，请单击广告”，你要让访问者知道这个广告会带给他们某种信息，而不是为了你才单击。

第二种：有代价的单击

如果你拥有某种十分吸引人的信息，而你想在不收费的情况下，得到某种利益(请允许这样说)，你可以让访问者必需单击旗帜广告，才能获得信息。

请参考以下站点页面源代码和实例：

http://member.zz.ha.cn/~qidian/sbg.htm

3.如何在NN4和IE4浏览器中浏览相同效果的字体？

我们制作页面时，利用IE4浏览器浏览时，一切很正常。但用NN4浏览时，发行细体字变成了粗体字了。这是因为，当你页面包含一段粗体字时，此时你复制了一段文本到该粗体字的周围，你会发现复制的文本也变成了粗体字，当然此时也可以再把它设置为你想要的字体大小，如果这样做了，我上面说的情况就会出现。你需要复制文本到页面空白处，这样文本不具有任何属性，然后拖动文本到合适的地方进行你需要的文本字体设置。这种情况多出现在利用FrontPage98编写网页。

4.如何让提交表单后打开一个新窗口显示提交结果？

如果你的站点上有邮件列表服务，每当访问者订阅并按下订阅按钮后。因为邮件列表需要订阅确定，而这种服务多为第三方提供的，所以订阅确定页会连接到服务商的页面。这样有时会照成访问者离开了站点。你可以按下面的代码设置，让访问者单击了订阅按钮后，会打开一个新的窗口显示订阅确定。

<form ACTION="http://www.popchina.com/cgi-popchina/mailist.pl" target="a" METHOD="POST">

其中在你的代码中加入：target="a"

5.如何防止页面源代码被复制？

如果你的页面包含一个自行设计的JavaScript小程序，如何防止它被别人复制使用呢。其实你不可能完全阻止他人引用，但你可以采用适当的方法尽量维护自己的权益：

第一.版权声明

在源代码中加入一段版权解释-<!----本源代码版权所有，请勿复制。---->，并把源代码利用E-Mail寄一份给自己，以确定时间，为以后与别人交涉做好证据准备。

第二.工具加密

你也可以利用工具软件加密源代码。详细设置请参考站点：

http://member.zz.ha.cn/~qidian/chinabyte.htm

6.如何清除页面中的框架结构？

在链接<A HREF>中加入TARGET="_TOP".如下设置：

<a href="http://lovett.163.net/" target="_top">田涛站点</a>

当你单击了这个链接，页面所有框架被清除并以该链接内容替代。

7.如何防止站点页面被任意链接？

有许多好站点的页面被其它站点任意链接，如果你不希望别人直接链接到站点内部去，你可以经常更换页面文件名。比如每十天改一次，这样可以有效防止别人的任意链接。缺点是让直接访问着无所适从。

8.如何创建一个下拉菜单？

我们在主页中常会用到下拉菜单，一般来说，它需要CGI程序支持。你也可以利用JavaScript编写一个。

<head>
<script LANGUAGE="JavaScript">
function formHandler(){
var URL = document.form.site.options[document.form.site.selectedIndex].value;
window.location.href = URL;
}
</script>
</head>

<body>
<form name="form">
<select NAME="site" SIZE="1" onChange="formHandler()">
<option value="请选择">请选择</option>
<option value="http://lovett.163.net/">新闻事件</option>
<option value="http://lovett.163.net/">软件下载</option>
<option value="http://lovett.163.net/">田涛撰稿空间</option>
<option value="mailto:lovett@163.net">给我写信</option>
</select>
</form>
</body>

9.如何避免页面电子函件地址被搜索到？

经常会收到不请自来的垃圾信，如果你拥有一个站点并发布了你的E-Mail链接，那么其他人会利用特殊工具搜索到这个地址并加入到他们的数据库中。要想避免E-Mial地址被搜索到，可以在页面上不按标准格式书写E-Mail链接,比如：lovett at 163.net，它等同与lovett@163.net.

10.如何给站点加入计数器并进行设置？

要给站点加入计数器需要第三方提供服务，目前这种服务非常多，而一般申请免费主页空间时会提供计数器服务。计数器格式如下：

<img src="http://202.93.140.57/cgi-bin/count.exe?dd=A;df=tiantao|ft=0" border="0"
width="60" height="19" align="top">

期中dd表示计数器的数字字体形状，一般可以选择A,B,C,D,E,F六种；df表示计数器的记录文件名字，一般为申请者的用户名字；ft表示字体的立体效果，可以为任意数字；计数器还包含md(定义计数器最大位数)，display(计数器功能)等属性。

11.创建一个好站点应具备什么知识？

*HTML的使用技能；
*WEB图形的使用；
*JavaScript编程；
*站点的布局计设计；
*管理站点的能力；
*写作能力，为站点内容服务；
*对WEB服务器的了解。

12.如何使图片与浏览器窗口无缝接合？

大家有时候发现想把一幅图片与浏览器窗口边框无缝接合很难，总会有点距离。这是因为你没有设置页面边距，在你的页面<BODY>中加入以下代码：

topmargin="0" leftmargin="0"

topmargin为与浏览器窗口顶部距离，此时为O，图片与浏览器窗口无缝接合。

leftmargin="0"为与浏览器窗口左边距离，此时为0。

13.如何建立一个站点的搜索引擎系统？

如果你的站点有许多内容，你希望访问者能很快找到他想要的信息。那么你需要建立一个搜索引擎。连接到网站网络特区http://netzone.swatou.com/personal/,单击"申请站点引擎"并填写申请表，再按照要求建立站点页面数据库即可。详细设置请参看：http://member.zz.ha.cn/~qidian/jq.htm

14.如何让文本与图像和平相处？

如果你有一段长的文本，并把文本缩排在页面中间部分，你希望在文本周围放置几幅图片，这该如何进行呢。假设你在使用FrontPage98编辑页面，首先设置好文本，然后在需要放置图片的地方，建立一个单行表格，并利用鼠标把它拖到最小，选择表格属性，把Float设置为right(表示放置在文本右边)，单击OK。这时，表格处于文本右边，最后把图片放置在表格中即可，记得把表格边框取消。


网页制作常见问题解答[四]

1.如何改变链接颜色?

要改变链接颜色，请在<body link="#FFFFFF" vlink="#FFFFFF" alink="#FFFFFF" background="bj4.gif">中设置.link为未链接颜色，vlink为已链接颜色，alink为链接过度颜色.

2.如何让访问者忽视缓冲页面？

请在<head></head>部分加入<MEAT HTTP-EQUIV="Pragma" CONTENT="no-cache">

3.如何为页面制作幻灯片效果？

如果想为访问者展示一系列的图片，并且页面自动每间隔一段时间刷新图片。假设要展示三副图片，为这三幅图片制作三个页面1.htm,2.htm,3.htm。在每个页面<head></head>部分分别加入<META HTTP-EQUIV="Refresh" Content=" 6;URL=x.htm">,其中1.htm指向2.htm,2.htm指向3.htm。

4.如何正确上传页面？

*服务器默认首页名字是什么，目前多为index.htm或default.htm。
*是否需要建立目录public_html,有的服务器需要建立该目录并把所有页面都上传到该目录下，有的只需要直接上传到根目录下(/)。
*服务器是否支持中文文件名(喜欢用中文文件名的网友要注意)。
*服务器对文件英文大小写是否敏感，笔者提议最好都用小写英文。
*检查用户名和密码是否正确。

5.如何为文字链接加上文字提示？

我们一般可以为图片加上文字提示，即ALT=田涛。如何为文字链接加上文字提示呢，只需在<a>中加入Title标签。<a href="http://webfaq.126.com/" title="网 页 制 作">网页制作</a>

(Interner Explorer 4.0支持)

6.如何改变表单submit按钮的文字？

把下面代码中的value属性值改成你需要的文字即可。

<input type="submit" value="submit" name="B1">

7.如何在IE4和NN4浏览器中精确定位图片？

精确摆放图片需要CSS(层叠样式表)的帮助，如下：

<html>
<head>
<title>tiantao</title>
</head>
<style>
.lovett

{

position:absolute;
top:100px;
left:120px;
visibility:visible;

}

</style>

<body>
<div class="lovett">

<img src="cww.jpg" width="130" height="191">

</div>
</body>
</html>

调节top,left的值来精确定位图片。

8.如何加快页面图片下载速度？

有种情况，首页图片过少，而其它页面图片过多，为了提高效率，当访问者浏览首页时，后台进行其它页面的图片下载。方法是在首页加入：<img src="tiantao.jpg" width=0 height=0>,其中width,height要设置为0，tiantao.jpg为提前下载的图片名。

9.如何自动弹出对话框？

在<body></body>部分加入

<script LANGUAGE="JavaScript">
alert("弹出内容")
</script>

10.什么是目标窗口，它该如何设置？

目标窗口是页面链接所指内容显示的窗口，也就是当你单击了页面某一个链接后，该链接所指的内容在那个窗口显示。大多数情况下，我们无需关心它，因为一般都是在同一窗口显示。

TARGET是链接标签<A>的属性，它的作用就是指定目标窗口，TARGET有以下几个值：

_self-将链接指向的内容装载到当前页的窗口或框架中

_top-完全取代当前页面的所有框架

_blank-为链接指向的内容打开一个新的窗口

_parent-把链接指向的内容装入当前页〈FRAMESET〉父窗口中

以上设置多用在框架结构的页面中。

11.如何为所有链接指定同一目标窗口？

在框架网页结构中，我们需要指定链接所指向的内容显示在那个窗口中。如果你的链接大部分都指定到同一个窗口中，就可以在〈HEAD〉〈/HEAD〉部分中加入：〈BASE TARGET＝“窗口名”〉，你无需为每个链接再指定窗口了。

12.如何让所有页面共享同一个层叠样式表(CSS)？

在每一个页面的〈HEAD〉〈/HEAD〉部分中加入以下代码：

<LINK REL="stylesheet" Type="text/css" HREF="tiantao.css">

其中tiantao.css为共享的层叠样式表文件，该文件可以利用文本编辑工具编写,它应包含如下的相似代码：

</style>
<style type="text/css">
<!--
A{text-transform: none; text-decoration: none;}
a:hover { text-decoration:none
-->
</style>

13.如何为链接定制新窗口？

我们可以打开一个新的窗口来显示链接的内容，但如何定制这个新窗口呢。

只需要在标签<A>中加入onClick事件:

<a href="#" onClick="window.open('tiantao.htm','help','scrollbars=yes,resizable=yes,width=500,height=40')">问答</a>

"#"表示单击链接"问答"后，当前窗口保持不变，tiantao.htm为单击链接"问答"后所打开新窗口装载的内容，而scrollbars=yes,resizable=yes,width=500,height=40为设置新窗口的大小等属性。

14.如何在没有安装更多浏览器的情况下测试页面？

目前存在的不兼容性，使得同样一个页面在不同浏览器中的显示是不一样的，如何尽可能使大家都满意呢，在没有安装更多种类的浏览器情况下，你需要关闭图片，JavaScript支持，CSS支持等等功能，因为大多数低版本浏览器都不支持它们，这样查看能让你知道页面在那里有多“难看”。

15.制作动态页面的步骤是怎样的？

第一步：设计页面及寻找页面需要的材料；
第二步：完成普通页面的制作，此时无须涉及动态主页内容；
第三步：为页面文字增加层叠样式表，以改变文字颜色，链接等；
第四步：为页面增加交互性内容，如CGI,JavaScirpt,ActiveX控件等，这是把页面动态的关键；
第五步：测试动态页面以适应更多浏览器；
第六步：发布动态页面并在上面标明该页是动态页面(DHTML)。


网页制作常见问题解答[五]

1.如何让访问者单击加入站点书签？

总希望访问者能能把你的站点，加入到他们的书签里，这里有个好办法：
在<HEAD></HEAD>部分加入：

<script language="JavaScript">
<!--

function addbookmark()

{window.external.AddFavorite("http://webfaq.126.com","网页制作问题解答");}

//-->
</script>

然后在<BODY></BODY>部分加入：

<script language="JavaScript">
<!--
if(document.all != null){document.write("[<a href=javascript:addbookmark()>按一下，我将和您永相聚。</a>]");}
// -->
</script>

2.是否可以利用大写体来书写HTML标签元素?

对于大多数HTML标签元素,你可以利用大写体或小写体及两者的混合体来书写标签元素。比如：

<html></html>和<HTML></HTML>同等有效。

但如果是特殊字符的标签元素，你只能使用小写体。比如版权的字符的标签元素是：&copy;，如果写成&COPY；，那么页面将完全显示&COPY；。

3.如何在页面利用单击来关闭浏览窗口？

在<BODY></BODY>部分加入以下代码：

<a href="javascript:window.close()" >关闭窗口</a>

4.如何为页面设置访问口令？

有时候你需要为某一页设置密码，以让合适的人进来。在<head></head>部分加入：

<script language="JavaScript"><!--
var pd=""
var rpd="tiantao"
pd=prompt("请您输入密码:","")
if(pd!=rpd){
alert("您的密码不正确...")
history.back()
}else{
alert("您的密码正确!")
window.location.href="zgr.htm"
}
// --></script>

在以上代码中,"tiantao"就是正确的密码。"zgr.htm"是当输入正确密码后链接的页面。这种设置口令的方法并不安全，因为只要访问者查看页面源代码就能知道设置的密码了。

5.如何为访问者设置正确的软件下载链接？

与其它链接一样，都使用<a></a>标签。但对于软件下载链接，你需要这样设置：

<a href="tiantao.zip">Download tiantao.zip (188kb)</a>

6. 如何删除图片链接的蓝色边框？

如果我们设置了图片为一个链接，会发现图片四周出现了蓝色边框。要删除边框，需要在图片标签里加上border="0"。如：<img src="zgr.jpg" border="0">

7.如何为链接提供一个按钮？

<form ACTION="zgr.htm" METHOD="GET">

<p><input TYPE="submit" VALUE="单击这里" NAME="tiantao"> </p>

</form>

8.如何为页面增加一个计数器？

这个问题对于初上网的人实在是个头痛的事情，因为他们发现在利用FrontPage98增加计数器后，发现根本都不起作用。计数器需要服务器CGI的支持，不能由本地的电脑自行设置。所以，如果你的站点需要计数器，请到以下这个最有名的计数器提供商申请吧：http://www.linkexchange.com/

9.如何知道站点的流量来至那里？

如果你拥有站点服务器的管理权，那么这是个很简单的问题，查查服务器日志就可以了。但目前你没有那权力，不过可以由第三方提供流量数据。易数是个不错的选择，链接到站点http://best.netease.com/申请，然后把代码加入到页面即可。当你想知道流量时，单击易数图标，在统计页面中，单击分析即可。

10.如何让浏览器正确显示word文件格式？

为了正确处理word等格式，你需要在HTML文件中设置好该文件类型，比如：

<meta http-equiv="Content-Type" content="Application/msword">

还有其它经常设置的文件类型：

Application/msword Microsoft Word Document
application/pdf PDF Document
application/wordperfect6.0 WordPerfect 6.0 Document
application/zip ZIP archive
audio/x-wav WAV audio format
audio/midi MIDI audio format
audio/x-pn-realaudio RealAudio
image/gif GIF image format
image/jpeg JPEG image format
image/png PNG image format
text/html HTML document
text/plain Plain text
video/mpeg MPEG video format
video/quicktime QuickTime video format
video/x-msvideo AVI video format

11.如何知道自己的图片被其它网站使用？

如果你为自己站点的图片起了一个独特的名字，也就是不容易重名，比如tt124.jpg.那么链接到站点：http://www.altavista.com/，在搜索栏里输入tt124.jpg.然后开始查找，如果有站点采用了tt124.jpg图片，该站点就会被列出。AltaVista搜索引擎是一个以机器人搜寻为主的站点，它的机器人会不停地把整个网络的页面作上索引，所以，你可以在那里找到和你相关的任何东西，把你的名字的拼音输输入看看，找到什么啦。

12.如何缩进文本段落？

在<head></head>部分加入：

P { text-indent: 1% }

P标签为HTML文本段落的标签，1%为缩进的范围。


网页制作常见问题解答[六]

1.如何正确使用分隔线？
如果你使用FrongPage98，这里我再假设你需要分隔页面左右两部分内容，先利用表格工具拖出三个横行表格，把内容分别放置到左右两个单元，然后把中间的单元的宽度设置为1个Pixels,并填入所需要的颜色。你还需要把所有表格及单元的大小单位都设置为Pixels即可。

2.如何单击链接打开一个定制的新窗口？
先在<head></head>部分加入代码：
<script language="JavaScript">
<!--
function MM_openBrWindow(theURL,winName,features) {window.open(theURL,123,features);}
//-->
</script>

然后在链接标签<a>中加入如下代码即可：

<a href="#" onClick="MM_openBrWindow('http://member.netease.com/~tiantao/','123','scrollbars=yes,width=640,height=480')">田涛站点</a>

3.为什么有的站点下载很慢？
因为网页用了过多的图片，为了追求COOL的效果用了大量的Java Applet，过多使用<TABLE>，这些都是不可取的。对于图片必须要用的压缩再用，对于Java Applet绝对不用，它会让机器配置低的访问者的硬盘狂读不止。对于需要的动态页面，可利用CSS和JavaScript实现。

4.如何让字体显示的更舒服？
这需要利用到CSS(层叠样式表)，目前约定俗成的字体是：{ font-family: 宋体(GB); font-size: 9pt; line-height: 16px }，把这段代码加入到<head></head>之间。如：

<head>
<style>
<!--
.font { font-family: 宋体(GB); font-size: 9pt; line-height: 16px }
-->
</style>
</head>
<body>
<p class="font">计算机世界报<br>
网页制作常见问题解答</p>
</body>

font-family: 宋体(GB)是设置的字体；font-size: 9pt是字体的大小；line-height: 16px是文本行的上下间隔。

5.如何让网页兼容IE和NN两种浏览器？
完全的兼容是不可能的。目前IE浏览器占有量大大超过NN浏览器，所以你只需要兼容IE浏览器即可。当然你也可以制作两套网页，利用JavaScript来检测不同浏览器以装入相应网页。

6.如何正确使用字体？
设置文本字体是网页制作中很重要的的环节，但因为并不是每一位访问者都有你设置的字体，所以尽量使用操作系统默认的字体宋体，黑体，楷体。对于其它类型字体可以用图形方式实现。

7.如何制作繁体版本网页？
如果你使用E-Port的网页作坊工具制作页面，那就可以利用工具菜单下的GB转BIG5来把简体网页变成繁体网页。如果你用其它工具也可以利用网页作坊的GB转BIG5来制作繁体网页，利用网页作坊打开页面，点选工具菜单下的GB转BIG5转换网页并保存。要注意的是，你需要把原<meta http-equiv="Content-Type" content="text/html; charset=gb2312">中的charset=gb2312改为charset=big5，这样，访问者的浏览器就会自动识别了。(E-Port的网页作坊下载地址：http://e-port.soim.net/)

8.利用水平线(HR)制作垂直线？
插入HR很简单：<hr size="1">。如何让它垂直呢，更简单：<hr size="100" width="1">。

9.与其它站点交换连接需要什么？
当然，你首先要有一个个人站点，然后准备好两个站点LOGO。一般来说，400x40 和 88x31两种LOGO是必需的，其它也可以准备一个100x31的LOGO。400x40的LOGO用于象网盟这样的广告交换站点，88x31和100x31用于个人站点之间的交换。

10.如何让下拉式菜单中的链接来打开一个新的窗口？
先把下拉式菜单设置好，如：

<form method="POST" >
<select name="D1" size="1">
<option value="http://member.netease.com/~tiatnao/">田涛站点</option>
<option value="http://webfaq.126.com/">网页制作常见问题解答</option>
</select><input type="submit" value="Submit" name="B1"><input type="reset" value="Reset"
name="B2"></p>
</form>

然后把<select name="D1" size="1">改为

<select onChange="javascript:window.open(this.options[this.selectedIndex].value)" > 即可。

11.如何正确对齐文本？
有时，我们需要对一段文本的左右，上下的边距(指文本至浏览器的距离)加以指定以使文本正确对齐，CSS(层叠样式表)提供这样的功能：
在<head></head>中加入

<style>
<!--
.tt { margin-left: 68px; margin-right: 70px; margin-top: 69px; margin-bottom: 71px }
-->
</style>

.tt为类名，以便你在HTML标签中应有。而在{ }中的属性及指分别为边距左，右，上，下的距离。当它们的边距都相等时比如都是60px，可以简写为： .tt { margin: 60px }.

当在文本中引用了该CSS，你会发现文本对的非常整齐。

12.如何正确使用图片格式？
目前在网络上的图片准标准格式为JPG和GIF。当图片颜色数很多时，就选择JPG，它的压缩比高，而GIF适合颜色数少的图片。

13.如何在网页上显示访问者系统信息？
把以下代码加入到<Body></Body>:
<script Language="JavaScript">
document.write(navigator.appVersion)
</script>

14.如何正确放置JavaScript?
JavaScript为动态主页的实现工具，一般来说JavaScript放置于<head></head>或者<body></body>之间。对于放置在<body></body>之间的JavaScript，你需要把它放置在适当位置。如果你用FrontPage98工具，先把光标移到想放置JavaScript的地方，然后选择Insert/Advanced/script，在打开的文本框中输入JavaScript，这样就放置好了。预览页面，JavaScript出现在你放置的地方。你也可以把JavaScript放置到表格中，这样可以精确定位。

15.个人站点需要那些交互功能？
交互是网络的魅力所在，作为个人站点也需要这些交互性的工具，以便和访问者随时进行沟通。以下是目前个人站点必备的交互工具：

留言板-让访问者给你的站点提提意见；
论坛-讨论某一个特定主题的地方，它和留言板的区别是留言板可以包含任何内容；
调查表单-利用个人站点，你可以对某一问题进行调查，然后看看各意见的支持率；
订阅表单-通过邮件给订阅者提供站点的更新信息；
聊天室-一个即时的对话场所，特别可以对一个特定主题组办一个网络讨论；
搜索引擎-当站点内容过多时，搜索引擎可以让访问者快速找到想看的内容；
小游戏-这个交互功能很少有站点提供，但该功能可以让访问者停留时间增长。


制作主页的五十个秘诀

译 金璐

一、内容

1、让读者有理由逗留。要把网页作得趣味盎然，引人入胜。但首要的是要让它有用处。这样做的一个很简单的办法是提供相互参与——让读者做一些事情，如报名获取定期发送的通讯，并用某种方式报答他们的参与，如每周抽奖或给予下载一些东西的机会。

2、对访问者来说最具价值的站点是那些立刻就能让人明白哪些信息可以获取，怎样获取，以及可能还有怎样让读者来更正他自己认为有错误的地方或加上他自己的内容。

3、签上自己的名字，并展示得到的荣誉——但不要在这里弄上一个长长的签名。少许的自我宣传可能是中肯的，尤其是当你想让自己的网页具有个人特色时，但这可能会带来困窘和妨碍实质内容。你所要作的只是连接到关于作者的那一页，该页也是弃权、版权声明及类似说明的合适地方。

4、不要包括一些一般化的Web参考信息和人人都有的已不再是热点的连接。连接到Alta Vista和Yahoo可能就已足够了，否则你的外部连接应该是具有特殊意义和读者还没有遇到过的地方。

5、要是有以评论或读者意见的形式取得的肯定性的反馈，可考虑把它包括在主页之内——也许在开头的某个地方，或者作为到荣誉页的一个连接。如果做得恰到好处，可以鼓励新的访问者并使他们放心。相反，要是做得不合适，就会被认为是自我吹嘘，而真正的内容反而处于次要地位。

6、忘掉已学会的在纸上写作的大多数习惯。基于文字、面向纸张的写作所面临的任务是精心安排的叙述，在提供知识、愉悦心情或说服别人的过程当中要能保持读者的兴趣；但是文字并不是大多数Web版面的主要组成部分——即便是页面上的文字比其他元素多，也常常是其他组成部分(图像、超媒体连接)被认为比单纯的文字更重要。

7、结构至关重要。网页可能会看起来是二维的，但不应如此理解。印刷页面的原有结构在Web已不复存在；写作者得着重于文件以可见的方式表现出来的结构，因为它可能已具有更微妙的交流功能。

8、Web的读者不会去读每一个词，他们的阅读方式更近似于快速阅读而不是象读呆板的树式文件那样的逐行阅读。通过计算机屏幕阅读并不是件格外舒服的事情，因此读者希望最好能尽快得到结果。

9、在Web页面创作中读者实际上是一个配合者。除了要注意在任何类型的写作中都要考虑的词汇、语调和其他事项外，网页作者还要意识和具体考虑到读者的身体运动——按鼠标键、滚动页面、写作邮件——也是交流过程的一部分。

二、页面设计

10、有了一个HTML编辑器和几兆服务器空间并不能说马上就可以设计网页了。在开始编写文字、寻找图像和进行HTML标记之前应该先把基本的网页结构组织号。如果没什么要说的，就什么也不要说。要是开始的时候在脑子里没有一个相当明确的结构，那几乎肯定会以一团糟而告终。开始时谨慎一些，然后不停地学习,不停地改进。卸载一些你喜欢的页面，核对HTML源文件，看它是怎样写的，把它全部或部分粘贴到一个试验文件进行检验。整页地拷贝别人的东西是剽窃行为，但是向别人学习则是研究过程。

11、人们第一次进入你的主页时，他们通常不是在寻找值得阅读的地方，他们可能正在寻找可供选择的东西，以超文本术语说即是可用鼠标点取的词句、图像、按钮等等，接下来是阅读文字，选定一个可选项，按鼠标键，下页出现后又重复此过程。这里的技巧是确定阅读时按键的适当比率。提供的可选项要是太少，访问者会觉得没意思，要是太多又会吓倒别人。

12、要是页面包含的内容信息量大，在开始设计页面之前就要先确定好读者对象。对新手或新的访问者来说用一种固定的文件结构并在开始的时候给予说明是有意义的。例如，关于内容的说明表格或某种类似结构。如果你要满足知识或经验不在同一个层次的读者，提供限制性的线索可以让某些读者跳过基本内容直达目标。提供连接时要考虑到各个层次的读者。

13、不要让读者不知所措。不必非要用声音和图像充斥网页，也不要把文件做得太长以至于在装载文件时让读者等得脚后跟发凉，因此使用图像时要谨慎：大的图像显然会降低页面建立的速度，但许多需要顺序装载的小图像也会如此。

三、布局

14、别轻易让文字居中和使用粗体或斜体字符。除了视感混乱之外，很多流览器不能很好地显示斜体字，也不能补偿由于字母倾斜引起的空白变化。

15、利用短的段落，加点列示，适当的整块引用文字，用水平线分节，用影象地图指引主要连接，使你的页面能吸引人和容易阅读。

16、不要在每一页使用风格不同的图标。

17、不必在以页面上填满图像来增加视觉趣味。尽量使用彩色圆点——它们较小并能为列表项增加色彩活力(并能用于彩色列表)。彩色分隔条也能在不扰乱带宽的情况下增强图形感。

18、对用作背景的GIF要谨慎。它们可以使一个页面看起来很有趣，甚至很专业，但是装饰背景很容易使文字变得不可辨读。要把背景做得好，光有颜色对比是不够的。背景要么很亮(文字较暗)要么很暗(文字较亮)。如果背景含有图像，对比度要较低才不至于过于分散读者的注意力。

19、在 IMG 行加 ALT 标记。假设标题图像显示为 The Offal Eaters' HomePage，你可以在括号内加上一个 ALT 标记，ALT="The Offal Eaters' HomePage"，直接把它加在 IMG SRC=Offal.com.uk/images/gif/home-top.gif之后。这样就会让使用基于文本的流览器的读者除了看到 [IMAGE] 以外还能看到别的一些东西，使用图形流览器的读者在图像未能成功载入之时也会看到一些东西，而你也能让自己的HTML文件相当整洁。

20、也可以在分隔条上使用ALT标记，这样就使得使用基于文本的流览器的读者能看到一些更有趣的东西，而不只是一条直线。

21、不要把重要的内容放到页尾——有些读者可能不会往下看那么远。

22、不要让什么东西看起来象是一个按钮却不起按钮的作用。

四、HTML格式

23、应避免使用交叉标记。不同的浏览器对交叉标记的反映会不同。

24、使用交织 GIF 和 Jpeg 。因为交织图像是分级显示出来的——首先以很低的分辨率显示，然后逐步提高分辨率，直至最后达到正常显示——这种方式有时候会使较大的图像看起来好象装载得快一些(实际上并非如此，但这是一种有益的错觉)。这样也便于读者在图像装载的过程中看到它的模样，如果他们不喜欢或不想看的话就有机会中断传输或转向别的地方。

25、另一种增加可得带宽的巧妙方法是在HTML底稿中使用 Lowsrc 命令。比如说有一张400×600像素的1600万色扫描图，所占空间约为35K。使用 Paint Shop Pro 这一类的工具对原图
重新取样，比如说高度为100像素(也许为了达到你自己的要求你得进行调整才能找到最合适的大小，但可以从高度除以4开始)，Paint Shop Pro 会自动计算新画面的宽度。保存新画面，它的大小现在应为6K或更小。然后在HTML文件中可以这样写上：
<img src="bigpic.jpg" lowsrc="smallpic.jpg" width="600" height="400">
Lowsrc命令指示浏览器在真正的画面载入以前先装载低分辨率的图像，这样就让读者清楚将会出现什么样的画面。(为确保浏览器能即时以合适的大小显示图像，高度和宽度很重要)。

26、当然，可以用 Lowsrc 提取你想要的任何图像。一条双色的“请等待下传”的信息可能只占几百字节，同时由于图像是存在浏览器的缓存区，因此可用“请等待”信息代替所有画面。当图像平静地消失于背景之中的时候，读者可以悠闲地浏览你的网页。

27、可以在一个 HTML 元素内嵌入一个连接，如：
<H1><A HREF="Destina-tion.html">Myheading</A></H1>
但不能反其道而行之，把一个标题或其他HTML元素嵌入一个连接。下面这样的结构是正式的 HTML 规定禁止的，并可能在大多数最新的浏览器下不见效果：
<A HREF="Destination.html"><H1>Myheading</H1></A>

五、长文件

28、当页面为单个长文件时要小心。它的传输时间明显要比较短的页面的传输时间长，即使通信速率为 28.8Kbps 的读者也可能会失去耐心。阅读大的文件时页面滚动也很困难。大的文件和较慢的装载速度可能会使人沮丧，再也不会返回到你的网点。

29、如果你觉得文件大小很重要，不便改变，就要考虑读者将会怎样使用网页。努力确保读者浏览长文件时浏览器滚动条小的移动不会在页面上产生大的跳跃。作为一条经验规则，按一次滚动条页面移动的范围要少于一页，这样就还看得见上一个窗口的部分内容。任何比这更大的移动都会让人迷失方向。

30、要不然就把一个长文件分成几个子文件，在主页给予连接。不过要记住子页可能会成为死页——有时候命中率要低于10%。做得聪明一点，给读者一个很好的理由装入子页或给他们一个很好的理由浏览它。

31、如果页面很多，在主页给出一个内容列表或目录显然是个好办法。不要非得作成那种常规的、令人厌烦的、死板的树形布局，把它做得有趣一些，让读者有理由进入连接，帮助他们了解他们可能看不出来的内容。

32、要是你必须把所有的内容都放在一个文件里面，使用一个内容列表，从表的项目可直接跳到各部分的开头。或者做得更好，提供一个独立的文本文件用于下传——去掉所有的格式符——使下传的时间减到最少。

六、连接

33、通常的顺序文本写作与在线文件写作之间的一个主要区别是在线文件的读者可能在文件的任何一点进入该文件。尽管你已做了一个漂亮的首页作为入口，其他人可能会对你的杰作内的具体指针或子页给出连接。向这些新的访问者提供一些关于他们在什么地方以及为什么在这里的线索是有意义的。

34、从头至尾都要使用导航图标，尤其是要用“返回到首页”连接。可以在每部分都做这样做。比如在每页的顶端(或底部)都有一小串图标，第一个回到首页，第二个回到章，第三个回到节。

35、在页面上应该有一些连接帮助访问者来回跳转。总是以相同的格式把这些连接放到所有页面上，这样读者就总能知道到哪儿去找到它们以及怎样使用它们。

36、一般来说应该使用相对连接，因为：(1) 这样容易把一组文件移到另一个地方(相对路径名仍然有效)，(2) 输入量较少。在同一页的连接项当然应该使用相对地址，因为使用绝对地址后可能会每选择一个连接都要把该页重新装载一次。

37、连接到不直接相关的文件时使用绝对路径。这样以后要是把源文件移到另外的目录下就不需更改连接了。

38、确保可选择的连接清楚直观——用标题或明显相关的图像来表明它有什么内容。特别要避免“请按这里”，任何要“按这里”的人都会慎重考虑，它是不是正好就在“这里”，并且连接无误。不要让连接的名称与连接的 URL 相同，这样会使读者要作的工作增加。

39、Mail to 连接中应把 e-mail 地址作为连接名称。例如，可能有一个人名和一个 e-mail 地址，人名连接到他的主页，e-mail 地址连接到 mailto。新闻组连接应当直接用组名。

40、核对 href ，不要在页内出现任何没有出路的连接，也不要让连接落掉。

七、通则

41、实际上，网页要么处于建设之中要么就是死的——如果你不更新它，并且它不是纯粹的历史资料，它马上就会变旧。“最后一次更新”记录是一个好办法。且不说别的，如果你的页面变化太少，你很快就会在读者评论中得到讽刺意见。

42、鼓励读者通过填表或发邮件反馈意见。但要准备处理随之而来的事务——要尽快地回E-mail，增加连接，修改输入错误等等。给通过 E-mail 进行评论的人回感谢信。

43、在页内告诉读者如果他们在自己的主页内设置一个指向你的连接你不会介意，并表明你也同样会设置一个指向他的主页的连接。每个人都希望有人访问自己的网页，而这种相互支持会鼓励对见解类似的网点的访问。

44、联机时间是昂贵的，而访问者的注意时间之短是众所周知的。想办法告诉读者下传要用的时间——告诉他们要出现的图像的大小或下传一个文本文件或二进制文件要用多久的时间。为把联机时间减到最少，指出你会给出FTP地点或提供到其他页的连接，读者会欣赏你的这种做法。

45、利用 Digital 的优秀检索工具 Alta Vista 找出谁已建立了指向你的Web的连接。在高级检索方式下，输入：
link:http://my.site.com/ANDNOTurl:http://my.site.com/
在简单查询中也可同样做到，输入：
+link:http://my.site.com/-url:http://my.site.com/

46、Web上的大多数写作都相当糟糕。由于多数网页都是空话连篇，自我吹嘘，编写粗糙，编辑审核也不存在，好的写作就很突出了。

47、不要忘记为你的主页加一个描述性的标题，当某个人把它保存在自己的热点目录后能知道这里是什么内容。

八、设备独立

48、HTML不包括文件显示时用到的字体、段落形式及空白信息。这正是它的意义所在，无论在什么平台上，包括文字终端，你的文件都能成功地显示出来。由此产生出最低命令标准。因此要了解不同的浏览器用不同的空白和字体。

49、假设你的页面要用某个特定的浏览器阅读时要当心。要是没有鼠标器，让别人“按这里”是不会有效的，如果你的读者使用 Internet Explorer 或Spry Mosaic，Netscape2.0 的插件就不会有效，除非你能保证读者有 Netscape 或 Internet Explorer 兼容的浏览器，否则重新调整过的图像可能会以预想不到的大小显示出来，表格也会很难看(或根本看不见)。在少数浏览器上，你根本不能看Jpeg图像。

50、不会有很多读者不能处理16位的图像，但是要注意，如果用16位(64K色)或24位(1670万色)的调色板制作精巧的背景，你可能会发现使用较老的设备的人只能跳过去。用8位图看彩色背景时会降为可怕的图形。带视卡但 RAM 少于 2M 的 PC 是不能观看图像的。


制作网页十大诀窍

转载自骄傲中华

    预早筹划
    设计主页未必很艰难。但这一工作与编制传统的宣传品一样，都需要我们谨慎处理和筹划。换言之，我们必须首先确定自己需要传达的主要信息，然后细意斟酌、把所有意念合情合理地组织起来；之后是设计一个页面式样，试用于有代表性的用户，接着重复修订，务求尽善尽美。

    尽量精简
    主页的作用好比一本书的封面，是为了吸引用户测览你的网址内容。因此，主页的设汁应以醒目为上、令人一目了然。切勿堆砌太多不必要的细节，或使画面过于复杂。在主页上清楚列出三项要点，例如机构名称、提供的产品或服务、以及主页内容(亦即你的其他页面还载有什么资料)。应切记页面给人的第一观感最为重要。在网上到处浏览的人很多。如果你的主页真没有吸引力，很难今他们深入观赏。

    尽量简朴
    现今大部分用户那是用调制解调器接驳万维网，所以他们一般都要花很多时间等待主页传送到自己的系统。切勿令他们加倍望穿秋水。主页上的图形应力求简朴，避免耽搁用户的时间。图像愈大、颜色愈深，传送页面的时间愈长。
    这并不是说你要完全略去图像不用，只是提醒你要注注意使用图像所引起的效果。
    主页上的颜色最好不超过六十四种，页顶图像最好保持在大约10KB(千字节)以下。切勿禁不住诱惑。觉得非要放入大幅的图画不可；应考虑只用三两幅短小精悍的图像。主页整体上要能够迅速传送。如果载入的时间超过十至十五秒，很多用户就会等得不耐烦。如果情况许可，最好先测试一中你的主页在稍差的条件下的传送速率，14.4千波特的调制解调器，或透过 Prodigy等网上服务接驳万维网等。
    此外、还须注意配合最低档的设备，例如标准的小型显示器，不要假设人人都用高解像度的大荧幕。运用先进测览软件所提供的一些尖端功能是可以的、但应确保你的主页在次一级的浏览软件上(例如某些网上服务所提供的专用浏览软件)仍可畅顺地显现。

    善用图像
    用户在网上四处漫游，你必须设法吸引和维护他们对你的主页的注意力。万维网的其中一个最重大资源是其多媒体能力，所以我们无论如何要善加利用。主页上最好有醒目的图像、新颖的画面、美观的字款，使其别具特色，令人过目不忘。图像的内容应有一定的实际作用，切忌虚饰浮夸。最佳的图像足集美观与传讯于一身。
    注意图画可以弥补文字之不足，但并不能够完全取代文字。
    很多用户把浏览软件设定为略去图像，以求节省时间他们只看文字。因此，制作主页时，必须注意将图像所戴的重要信息或联接其他页面的指示用文字重复表达?次。
    用纯文本模式测试已制成的主页，确保其传达到所有信息。

    使主页易于漫游
    主页的其中一个主要功能是作为漫游工具，指引用户查阅你存储在网址或其他地点的信息。尽量使漫游过程不费吹灰之力。基于清晰明确和速度的考虑，主页上的联接项目应只限于几个高级的类别，例如公司、产品、服务、支援等。
    用六至八个联接项目最为理想。
    此外，你提供的信息不应埋藏在重重叠叠的页面之下。穿越五个以上的联接项目已足以令人厌烦。因此，你必须在广度和深度之间求取平衡。如果你的网址上有太多信息，你可能要编制较长的页面或使用更多联接项目，甚至可能要建立多个主页、使每个主页载有不同的信息。如果能够让用户在主页上以关键字或词语查找所需的信息，肯定受用户欢迎。
    假若你有充足的资源，便应找一位专家来评估你设计的主页是否方便易用。设法找一些对主页陌生的用户，来试用你的初步制成品。

   提网协领
    主页一般须载有以下事项：
    ★标题
    此标题须清楚无误地标示你的网站。标题可以是名称、标语徽号或图像。
    ★电子邮件地址(例如你的 Webmaster)
    以便用户有问题时，可以通知你。
    ★版权资料
    这是适用于主页内容的版权规定。
    你可以在主页上标示一句简短的版权声明，用联接方法带出另?个载有详细使用条款的页面。这样可以避免主页显得乱糟糟。
    ★联络资料
    列出通讯地址、公关或营业部门的电话号码等。

    循环利用现有信息
    制作主页(或其他主页)时，通常都毋须从头做起，因为有许多现成的文字、图画等资料可供我们重用，例如宣传小册、公关文件、技术手册、资料库等。很多情况下，只要用少许功夫、就可把这些材料转到网页上使用。

    保持新鲜感
    万维网上不断有新事物出现、每天都有新花样。如果你的主页从不改变，用户很快会厌倦。在主页上预告即将有新资料推出，可吸引用户再来测览。不妨在页头以大字标题宣布新消息。可以定期改变主页上的图像、或更改主页的式样。
    趣味性的事项可以持续或自动更新、例如列出会测览你的网站的人次。
    同样，为保持新鲜感，应时刻确保主页提供的是最新信息。
    将更新主页信息的工作纳入既定的公关及资料编制计划内，亦即当你使用传统方法(例如新闻稿)传递的新信息、会问时出现在你的主页上。确保连接项目运作畅顺，以免用户在荧幕上收到?无法查阅所需档案?的信息而大感没趣。

    贯彻诺言
    做不到的事情，千万不要轻易承诺。切勿随便叫用户作出回应行动，例如要求用户填交订贷表格，除非你已制订好处理这些订单的方法和交货程序。如果在网上列出联络电话、就要确保自己能够迅速解决来电者的问题。

    吸引用户测览
    既然绞尽脑汁把主页弄得美观实用，没有人来欣赏就太可惜了。为吸引所有网中人来浏览，必须使主页易于寻找。
    通知其他网站(例如题材相关的网站)，他们可能想联通你的主页。安排将自己的网址列在所有相关的网址目录、索引、查找程序和?What? s new?页面上。尽量将网址传播开去，使之出现在 Internet和所有传统煤体上、例如书刊广告、公关文件、宣传品等。
    在网站上，于每个页面设置home按键，方便用户随时返回主页。
    万维网充满生命力、正在不断演进，所以一些现时适用的经验，将来未必合用。举例来说，将来家居用户有高速线路接驳Internet，就可以消除数据传输目前的所受的限制、使主页的篇幅可以更长，页面更华丽。新的浏览功能、例如Sun的 HotJava测览软件所提供的先进功能、将使万维网更强劲和更方便沟通。 HotJava将主页由静态的文件转为动态的实体，提供诸如即时制作动画、背景音乐、即时存入资料(例如不断更新股票价格)、话音广播等功能、为网上用户带来更多乐趣。
    有好的主页，还须有精良的设备支持。网站服务器不断推陈出新，使建设网站的工作愈来愈容易。以 S u n的NetraInternet Server为例、全套设备包括上网所需的软硬件、以及建立完善的高效能网站所需购各种软硬件设施。
    这些发展为万维网及其用户开拓了壮阔的前景。建设网站的上作，从未如此容易过。


一分钟网页设计技巧

作者：恒

一、保持网页的朴素
二、简单并不等于乏味
三、了解你的读者
四、五个“手指”
五、三次点击
六、三十秒的等待时间
七、平衡
八、 适度的帧
九、坚持学习

一、保持网页的朴素

一个好的网站最重要的一点就是界面的简单、朴素。你听说过“KISS”法则吗？ “Keep It Simple Silly.”适用于所有的站点。
制作者们很容易掉入这样一个陷阱，即把所有可能用到的网页技巧，例如：框架、表格、字体、GIF动画等等都用上，这当然是好的，但如果多了的话就会让你的访问者眼花缭乱，不知所措，也不会给他们留下很深的印象。
记住，只是因为你可以创建一个效果，但并不意味着你必须创建这个效果。先问一问你自己：我在网页上加入这个技术有什么价值？是否能更好的向访问者表达我的主题？

二、简单并不等于乏味

简单的真正含义并不是迟钝和乏味。许多人会被网站多余的奇特效果所迷惑，而忽视了信息的有效性。

保持简单的真正含义就是：想一想如何使自己网站的信息与你的访问者所期待和所需要的一样。应该把技术和效果用在适当的地方，用在有效信息上，让访问者关注他们想关注的东西。

清晰的设计＋有效的技术＝一个好的站点

Top

三、了解你的读者

你不是在真空里制作你的网页，也不是作给你自己看的。如果是这样，你还不如把它放在自己的电脑里。你发布你的网站是希望某些人停下来参观它。而这些人就是你的读者。

你越了解你的读者，你的网站影响力就会越大。你的读者是否有个慢猫？那你最好应当特别的注意网页的大小；他们希望听到音乐片断吗？你就要想想网页上的音乐格式。你的读者是纺织工人？那么血红色和黑色最好不要选择；或者他们是骨灰级游戏玩家？你就要避免用柔和的颜色和图案了。

一个好站点的定义：

通过典雅的风格设计提供给潜在读者高质量的信息。

四、五个“手指”

对一个好的网站来说，清晰的导航也是最起码的标准。应该让访问者知道自己当时在网站中的位置，并且愉快的通过你的指引而遍览你的网站。例如，你可以做到的一件事情就是：“下一步”的选择数目尽量少，以便人们不会迷失在长长的选择项目列表中。

你知道吗?一般人的大脑把五个或更少的项目看作一组，但是当所面对的项目超过五个，它就必须把他们划分成较小的次组来处理，所以说，保持你的选择项归类在五组或五组以内就变得很有意义了。你的访问者能够快速的找到自己想选择的项目。

Top

五、三次点击

对网站制作者来说，访问者就是上帝，讨好上帝的另一个方法就是让他们在获取信息时不要超过三次点击。想想，当你在访问一个网站时，点击。。。点击。。。点击。。。再点击。。。再。。。才找到你想要的信息，或者还没找到，你会怎么想呢？

加之，当你的访问者深入网站查找需要的信息最后却摸不着头脑了，会怎么办？他们肯定不会原地兜圈，他们会离开你的主页去别的地方继续冲浪，可能也就再也不会回来了。

六、 三十秒的等待时间

访问者进入你的站点后，他应该可以不费力的找到所需要的资料。有一条不成文的法则：当访问者在决定下一步该去哪之前，不要让他现在所看的页面下载的时间超过30秒钟。如果超过了这个时间，你就会开始失去你的“上帝”了。

保证你的页面有个适度的大小而不会无限制的下载。如果你的大多数访问者使用Modem的话，试着保持总的页面大小（包括页面图像）在45K一下。

确保你的页面设计规划清晰明了，让访问者只需快速的扫视就能把握你的网站导航，知道自己“下一步”该选择的项目。

Top

七、平衡

平衡是一个好网站设计的重要部分。

文本和图像之间的平衡。除非内容决定了这是个完全文本或者完全图像的网站，你需要用直觉和审美观来作判断，以便其中的一个不会淹没另外一个。

下载时间和页面内容之间的平衡。当然你希望有个漂亮的页面，但你也必须平衡你的页面内容，因为你的很多访问者正在通过modem阅读它。难道你网站的图片真的值得等待那么久吗？

背景和前景之间的平衡。我们能在白纸上画出美丽的图案，网页上，如果能制作出漂亮的结构和背景是很令人激动的。但也容易使你的内容淹没在你的背景里面。

八、适度的帧

适度的的帧对于你的网页是很好的补充，然而就像所有网站的元素所具有的特性一样，你绝对不要滥用他们！

如果你想创建一个可以看得到的导航结构，比如说一个表格目录，帧就是一个很合适的途径，例如，这页有三个帧－－你现在所看到的内容，导航条在右边，题目、广告和说明栏在顶部。

但是帧不是“万金油”。比如说，如果你想用行或列来显示信息的话，表格会更好。

九、坚持学习

创建网页是一个不断学习的过程。推出你网站的第一个版本还只是一个开始！技术和工具在不断的进步，而我们对人们如何利用网上资源的方式的了解也是在不断的变化，要创建一个好网站你就不能陶醉在过去的成绩上。

看看其他的网站。如果你想成为一个出色的小说家的话，你必须不断阅读其他好的作品。如果你想成为一个出色的剧作家的话你必须多看好的电影。同样，如果你想设计一个出色的网站的话，你必须多看其他好的网站。但你在看一个网站的时候，你能找到这个网站的优缺点，注意哪些是你该学习的，而哪些错误是你要避免的。

查看原文件。当你看到某些你喜欢的东西，使用你浏览器上的查看原文件的功能，看看这个效果是如何作出来的。在页面之后你能发现令你惊奇的东西。

阅读和学习。学习你尽可能学到的技术和设计方法。

Top

返回